Poprawka: .NET Framework 4.7 nie jest obsługiwany w tym systemie operacyjnym

.Net Framework to infrastruktura programistyczna wprowadzona przez firmę Microsoft. Będziesz potrzebować .Net Framework do uruchamiania różnych aplikacji i usług. Większość aplikacji, które wymagają .Net Framework, jest również dostarczana wraz z plikami instalacyjnymi. Tak więc zostanie automatycznie zainstalowany w systemie podczas instalowania aplikacji. Jednak podczas instalowania aplikacji może pojawić się błąd „.NET Framework 4.7 nie jest obsługiwany w tym systemie operacyjnym”. Ten błąd uniemożliwi pomyślną instalację aplikacji. Możesz zobaczyć ten błąd podczas próby zainstalowania .Net Framework jako samodzielnej aplikacji / usługi.

Powód wystąpienia tego błędu jest taki sam, jak wspomniano w komunikacie o błędzie. Mimo że .Net Framework jest obsługiwany w systemie Windows 10, ale nie jest zgodny ze wszystkimi wersjami systemu Windows 10. Jeśli więc widzisz ten komunikat, najbardziej prawdopodobną przyczyną tego błędu jest to, że używasz wersji systemu Windows 10, nie jest kompatybilny z .Net Framework.

Metoda 1: Zaktualizuj system Windows 10

Jedynym rozwiązaniem tego problemu jest po prostu zaktualizowanie systemu Windows 10. Zaleca się sprawdzenie dostępności aktualizacji systemu Windows, nawet jeśli korzystasz z najnowszej wersji systemu Windows 10. Ponieważ problem jest spowodowany przez niekompatybilny system operacyjny, zainstalowanie wszystkich dostępnych Windows 10 aktualizacje najprawdopodobniej rozwiążą problem. Możesz również sprawdzić dokładną wersję swojego systemu Windows 10 i wersję wymaganą przez .Net Framework, wykonując czynności podane poniżej.

  1. Przytrzymaj klawisz Windows i naciśnij R.
  2. Wpisz winver i naciśnij Enter

  1. Twoja wersja powinna zostać wymieniona w nowo otwartym oknie. Liczba po wersji (w drugim wierszu) to numer wersji. Powinna to być liczba 1507 lub 1709. Pierwsze 2 cyfry oznaczają rok, a drugie 2 miesiąc. Więc jeśli masz wersję 1709, oznacza to, że używasz wersji wydanej we wrześniu 2017 roku

  1. Teraz musisz się upewnić, że masz wersję systemu Windows 10, która jest zgodna z .Net Framework. Kliknij tutaj i kliknij Wymagania systemowe

Jeśli spojrzysz na sekcję Obsługiwany system operacyjny , jest tam napisana Rocznicowa aktualizacja systemu Windows 10 i aktualizacja Windows 10 Creators . Ponieważ wiele osób nie zna numerów wersji związanych z aktualizacjami Anniversary i Creators, wspomnieliśmy o nich poniżej

  • Aktualizacja listopadowa (1511)
  • Aktualizacja rocznicowa (14393)
  • Aktualizacja twórców (1703)
  • Aktualizacja Fall Creators (1709)
  • Aktualizacja wiosennych twórców (1803)

Jak widać, Rocznicowa Aktualizacja ma numer wersji 14393, a Aktualizacja dla twórców ma wersję 1703. Jeśli więc masz wersję niższą niż 14393, nie będziesz mógł zainstalować .Net Framework 4.7 w systemie Windows 10. Teraz po prostu zaktualizuj system Windows i upewnij się, że masz najnowszą wersję systemu Windows 10, i spróbuj ponownie.